Correct Baking Hard Surface Objects in ShaderMap?

edited March 21 in ShaderMap 4

Hello

Correct Baking Hard Surface Objects in SahderMap?

My process

Modeling
1.Low-poly
2.High-poly
3.Smoothing Groups

UV Unwrap
4.Creates UVW Shells based on the Smoothing Groups (Flatten).
5.hard edges separate UV islands.

ShaderMap
6.Quick Start Guide
7.Baking Normal Maps using Cage Projection (instructions)

Visual Check
8.Problem
I have seams in hard edge.

image

image

Thanks

Comments

  • Hi bruoj,

    That is strange. I wonder if its an artifact of the 3d visualizer or if the artifact is baked into the resulting normal map. If you can please provide me with a download link to the high and low poly models, I can debug what is happening and hopefully provide a solution.

    All the best,
    Neil

  • ok
    Send the files to support.
    You can give an example like baking hard surface objects - Tips.
    Even after the perfect bake, seams can still be visible.

    I have tested the model in MT3 and SP and normal map is created fine.

    My end goal is create textures for use in UE4 and Octane render.

    Note:
    FBX export option - disabled - tangents and binormals.
    ShaderMap DirectX true?
    Load high poly first true?

  • Excellent, thank you. I have received the model files and will investigate and report back.

    It is okay that you exported FBX without tangents and binormals, ShaderMap generates those on import.

  • I've been able to replicate your artifact bug. It seems like the Push Tool isn't positioning the polygons in a way that produces clean paths for the projection vectors. I have flagged this for further investigation. I recommend that you try the following:

    1. Use an external 3D model editor to shape and position the low polygon version so that in wraps perfectly around the high polygon model. Export it to file.
    2. Import the modified cage model into ShaderMap and attempt to bake without using Push or Scale tools on the cage geometry.
Sign In or Register to comment.