Home ShaderMap 4

Copy File Error [Solution]

edited May 2023 in ShaderMap 4


I've been using Shadermap for awhile now, and find the program to be amazing speeding things up quite a bit, and it has become a highly favorite tool of mine to use.

However, after my complete system reformat and windows reinstall, i continue to have a error message with Shader map 4 Which looks like this:


It's a Screenshot uploaded to ImgBB to show the error. In short, SM 4 cannot copy the templates from the installation folder to my folder in my documents.

Things i tried:
Reinstalling multiple times
Checking if my antivirus isn't blocking or interfering
Manually places the template files in the location
Downloading an older version (which got the same error, but gotten past the template error, then gave another error)
Checking an topic from a person with a similiar issue, however, nothing seemed off and nothing has helped either.



  • As an additional note: also made sure all the folders in appdata were removed.

    Still same issue, but the log file says the following:

    • "Application Initialization" - wWinMain() shadermap.cpp:295
      • "Create Application Window" - wWinMain() shadermap.cpp:308
      • [** WARNING ** "Open File Failed"] "Failed to open options file." - shadermap_options::load() shadermap_options.cpp:1313
      • "Initialize Direct3D" - wWinMain() shadermap.cpp:583
      • "Initialize Resources Pre-Splash" - wWinMain() shadermap.cpp:609
      • "Initialize Splash" - wWinMain() shadermap.cpp:630
      • "Initialize Material Plugins" - wWinMain() shadermap.cpp:740
      • "Initialize Map Plugins" - wWinMain() shadermap.cpp:767
      • "Initialize Geometry Plugins" - wWinMain() shadermap.cpp:795
      • "Initialize Filter Plugins" - wWinMain() shadermap.cpp:824
      • "Initialize Additional Resources" - wWinMain() shadermap.cpp:854
        [** ERROR ** "Copy File Failed"] "E:\ShaderMap 4\res\templates. -> C:\Users\Administrator\Documents\ShaderMap\SM4_3\Libs\Template." - copy_directory_contents_to_directory() file_dialog_functions.cpp:853
        [** ERROR ** "Copy Files Failed"] "Failed to copy template lib to user documents folder." - ui_start::initialize() ui_start.cpp:486
        [** ERROR ** "Initialize Start Failed"] "Failed to initialize Start control." - initialize_resources_post_splash() resource_functions.cpp:156
        [** ERROR ** "Initialize Resources Failed"] "Failed to initialize ShaderMap resources. Exiting application." - wWinMain() shadermap.cpp:858

    Seems the error starts with Failing to open the options file.

    Hope this helps.

  • Hi Melvin,

    Lets start with your ShaderMap installation location. It looks like its in "E: \ ShaderMap 4".

    I am betting that Windows doesn't like something installed outside of "C: \ Program Files" having access to the user directories. I would do an uninstall, then try installing ShaderMap in the default location for Windows applications and see if that allows it to have read / write access.


  • Hi Neil,

    Thanks for the Reply, I tried reinstalling to the C drive, but unfortunately, that has not helped and encounters the exact same issue.

    Before my system format, this was not an issue and everything was working fine, but it's now that it's causing an issue (and also the only program on my PC which is causing an issue, all the rest is working fine like it should)

    I'm beyond knowing what to do, and even already tried tweaks to take full ownership and control of both the documents folder and shadermap folders, but still won't budge.

    Also, i'm on a full admin account with full access to everything, so that also is not the issue.


  • Ok, after a lot of struggling i have found the fix.

    What was apparently the issue preventing it from working:

    In the documents folder properties, i disabled "Allow files in this folder to have contents indexed in addition to file properties"

    In the installation location, i disabled Both the same option as above, and "Folder is ready for archiving".

    Apparently, when these options are checked for the SM4 folders, it prevents SM4 from working properly, after i turned those off, SM4 loaded up without error.


  • Thanks for posting your solution. On my systems, I have those options enabled and it doesn’t interfere with normal operation.

    Perhaps this will help someone else having the same issue.
  • Can confirm this fix works. I emailed Shadermap with this exact issue and they directed me to this forum post. I tried the methods posted by OP and it solved my issue.

Sign In or Register to comment.