Home ShaderMap 4

ShaderMap 4.3.5 Crash at Launch [Fixed]

edited May 6 in ShaderMap 4

Recently my HDD crashed, and apparently the recovery/restore of my clone did not work in some cases for some of my apps. This is the only one I have left to resolve. I've removed/reinstalled multiple times, to different drives, even SSD to not avail. Each time I launch it I get the following error, pop-up: " Initialize Override XML Failed"..."Failed to create user Documents folder." - initialize_map_plugins() map_plugin_functions.cpp:3363" [end of error message]. Only option is to choose OK and then app splash screen crashes.

I love this program and its a daily use of mine. I hope this can be resolved. Thanks for any assistance anyone might be able to provide.

Gary

Comments

  • RSIRSI
    edited April 18

    Locate the following file on your system:

    "C:\Program Files\ShaderMap 4\res\xml\default_filename_overrides.xml"

    Copy it to the following directory:

    "C:\Users\USER NAME\Documents\ShaderMap\SM4_3"

    If that directory doesn't exist then please create it before copying the "default_filename_overrides.xml" file to it.

    Try to open ShaderMap 4 and let me know the results.

    Please let me know if the directory or the xml file were missing on your system.

  • The directory path ...Documents\ShaderMap\SM4_3 did not exist, I created/added it as you laid out and copied the xml file (which did exist in Program Files\ShaderMap 4\res\xml) folder. Still get same error, should I remove the app and reinstall it?

  • RSIRSI
    edited April 19

    Thanks for trying that Gary,

    Next I'd like you to download and install both Microsoft Visual C++ runtimes from the links below. Try to run ShaderMap again. You may need to restart your system after installing the runtimes.

    If this doesn’t work, I have placed additional instructions below.

    Neil

  • RSIRSI
    edited April 19

    Another thing you can try is to make sure that the User Documents folder is setup correctly in the registry.

    Navigate to "This PC" in the Explorer window and you will see the Document folder.

    1. Right Click the Documents Folder and select "Properties"
    2. Select the Location Tab
    3. Press the Restore Default button
    4. Press OK to close the Properties and make the changes

    Try ShaderMap again.

    If that doesn't work then you can verify that the registry was setup correctly for the User Document folder.

    1. Right click the Windows logo (bottom left on your task bar) then select "Run"
    2. Type the command regedit to bring up the Registry Editor. Be careful not to make any changes to keys or values.
    3. Navigate to "HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders"
    4. Locate the key called "Personal" It should have a value that is the full path to your user documents folder.

  • The C++ runtimes only provided a Repair option, as it seems they are already installed (which I've noticed each time I tried to uninstall/re-install SM4. So, I ran the repair and it was successful. Ran SM and it failed to same error as from the beginning of all this.

    The 2nd thing you wanted me to try with the Documents folders properties is a bit a problem. As it stands now I have several users with Documents folder There is only one that has the familiar icon for the Windows ..Documents folder. The other one's are the one's I created since posting this issue herein. Bottom line is none of them have a Location tab.

    In checking the registry, the Personal Key, has a wrong value. It shows the drive letter that has been replaced, as its the one that failed. That drive letter is M, which no longer exists. I was tempted to put the path in to what I figured it should be. But, you said not to change anything. So, I suspect that your suspicions on this are correct.

    Waiting on next step. :)
    Thanks for all you help with this.

    Gary

  • RSIRSI
    edited April 19

    In checking the registry, the Personal Key, has a wrong value. It shows the drive letter that has been replaced, as its the one that failed.

    First make sure you know where your Documents folder is located on the hard drive. You can find it in "C:\Users\YOURUSERNAME". It is just called "Documents". Once you are sure of the location and that it exists then follow the next steps

    1. Open regedit, navigate to "HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders"
    2. Double click the Personal key name to bring up the "Edit String" dialog box.
    3. Enter the correct path to your Documents folder (DOES NOT have a trailing slash) then press OK to save the changes
    4. Don't leave regedit yet. Try to start ShaderMap

    If all goes well, then you have entered the correct location of your Documents folder and ShaderMap will be able to find it and write to it.

    The other folder that ShaderMap needs to locate and use is AppData. You can see the AppData key on the same registry page. If ShaderMap has a problem opening with an error locating that folder, then you may need to locate and edit that registry key as well. Most likely that will be okay.

    Hope we are getting close to a solution for you. :smile:

    Neil

  • 1st change to Registry (wish I could post images here) did not resolve the issue, same error. AppData is properly set to the correct path. :(

  • RSIRSI
    edited April 19

    Try to reboot your computer and see if that works.

    If it doesn't work, try to Right Click on the Documents folder again and see if the Location tab is now available. If so, Reset to Default and press OK.

    This is such a strange situation. I am considering making changes to ShaderMap so that if the Documents folder isn't found then to ask the user to define a user data folder in the options.

  • OMG! ok, reboot did not resolve it, but as I was looking at explorer for the documents folder I noticed a Documents folder that said it was on my old failed drive! WTF! lol. Anyway, checking its properties I did in fact find it was pointed at that old M drive. I changed it to the C drive proper path, and now SM works! Woooo Hoooo!... btw after changing that path, explorer no longer showed it as the old M drive. This blows me away! But, am sure glad SM works! Thanks a ton for all your help!

    Makes me wonder if the registry change from above, and after the reboot, the what was then obviously pointed at that old drive became apparent, when it wasn't there before. I got lost long time ago! LOL

    Gary

  • HAHA! Your reaction is worth all the effort :smiley:

    Glad you were able to get it working.

    I am going to add a ShaderMap option to define an alternate Documents path for ShaderMap. If someone else runs into this problem, then it can be resolved quickly with a one-time info popup followed by a Folder Dialog.

    All the best,
    Neil

  • Thanks again for all your help, and you really do have an awesome app here with SM. Please keep it up! I agree with your proposed ultimate solution. I only wish recovering from a clone did what its supposed to do. At this rate I've had to re-install about 12 different apps. I don't think I'm done with that, but don't want to go through them all at this time. I'll fix them as they come! :)

Sign In or Register to comment.