Trying to do a batch save, and have it save each set of files to a different directory

So, I got the program today and I am trying to have it do a batch save to a different directory (based on source file name) for each input file in the batch.

I have opened default_filename_overrides.xml in the documents folder under ShaderMap

I have edited it and the single map save works great but the batch ones save them all to one directly called %source_filename%

Here is a sample of the code in my .xml file

<!-- Albedo (Light Scan) -->
<map_lscan_to_albedo output_directory="\%source_filename%" filename="%source_filename%" suffix="%default%" />
<!-- Normal (Light Scan) -->
<map_lscan_to_norm output_directory="\%source_filename%" filename="%source_filename%" suffix="%default%" />

<!-- Blank -->
<map_blank output_directory="\%source_filename%" filename="%source_filename%" suffix="%default%" />
<!-- Normal Blank -->
<map_blank_norm output_directory="\%source_filename%" filename="%source_filename%" suffix="%default%" />

I have tried it with and without the"\" before source_filename

Comments

  • Update: It doesn't actually save the filename correctly either, it also says %source_filename%

  • It looks like, in most instances, the system doesn't scan for %source_filename% when used in the output directory attribute. I've added this to the bug list and it should be fixed in the next update. Planning on early April for the next update.

    Thanks for bringing this to my attention.

Sign In or Register to comment.