Displacement Maps Not Seamless, Even when the Source Image is Tileable?

edited April 12 in ShaderMap 4

This is what happens when i generate my displacements
Seamless Source Image
Generated Displacement

When i generate maps they all turn out seamless expect for Displacement Maps generated from a Diffuse. Can this be fixed? I suspect that the source images is being blurred during the process of creating the Displacement. I'm not sure if this is what happens but if so A way a fix could be done in order to retain the shamelessness is by extending the image first. By repeating the texture on all sides including corners first, based on a configurable buffer size(in pixels). If a blur is performed, the edge pixels are no longer at the edge. This means the blurred can accurately retain the shamelessness as it now knows what to blur with the edge pixels. Finally the output's edge pixels are trimmed back to original size of the source image.

If anyone has any other work around or solutions that can be done i'd really like to know. Thanks :)

Comments

  • This is my source image where those seams are showing up

  • RSIRSI
    edited April 9

    Hi TheWizardLord,

    Firstly, the provided source image (rock texture) doesn't appear to be tileable. ShaderMap won't produce tileable images but can work with existing tileable images.

    When working with tileable images, Select the Source Map in the Project Grid. In the Map Properties, set the Tile Type to On XY. This should inform the displacement map plugin to generate smooth seams on both X and Y directions.

    If you try my suggestion, and still get a seam, let me know. I will find out what is happening.

    Best,
    Neil

  • Hey neil,
    Oh sorry no the image does tile i just didn't upload the full texture i screen grabbed where the seams were appearing If you overlay them you can see. But there's no need as your tip fixed my issue so thanks heaps, it was very frustrating.

  • Glad you were able to get the seams fixed.

    You can set the default tile mode in the options (for all source maps) under:

    Options -> Maps / Project -> Default Source Map Tile Mode

    Hope this makes things easier for you.

    Best regards,
    Neil

Sign In or Register to comment.