"LUA Script Error"

Hello, i using your software for modding in Black Ops 3 Mod Tools and its very useful, always worked perfectly till an update comes out and do some LUA error, here is the log : 

[size=small][font=Whitney,]+ "Start LUA Script Thread" - lua_script_thread() lua_script_thread_functions.cpp:5282
   [[/font][/size][size=small][font=Whitney,] ERROR [/font][/size][size=small][font=Whitney,]"LUA Script Error"] "sm_add_source_map_node() - Failed to create new map object: src_color_texture.smp. See main log for additional details." - lua_script_thread() lua_script_thread_functions.cpp:5590[/font][/size]

[size=small][font=Whitney,]Thanks in advance :)[/font][/size]

Comments

  • emox wrote:
    Hello, i using your software for modding in Black Ops 3 Mod Tools and its very useful, always worked perfectly till an update comes out and do some LUA error, here is the log : 

    [size=small][font=Whitney,]+ "Start LUA Script Thread" - lua_script_thread() lua_script_thread_functions.cpp:5282
       [[/font][/size][size=small][font=Whitney,] ERROR [/font][/size][size=small][font=Whitney,]"LUA Script Error"] "sm_add_source_map_node() - Failed to create new map object: src_color_texture.smp. See main log for additional details." - lua_script_thread() lua_script_thread_functions.cpp:5590[/font][/size]

    [size=small][font=Whitney,]Thanks in advance :)[/font][/size]
  • Hi emox,

    Could you please post the script that you are using?

    Thanks,
    Neil
  • RSI wrote:
    Hi emox,

    Could you please post the script that you are using?

    Thanks,
    Neil

    Hi,

    I dont use any scripts or something just drag and drop and image to create the other images and its do this, its depends on images and now its says "Unable to load image from file. Unknown reason - create_new_map_object() map_plugin_functions.cpp:3374" .

    I just using the software without any addon, plugins or scripts, thanks.

    EDIT: Its works now, i rename the extension file of the image, .jpg to .png, looks like .jpg are not supported or something.
  • Oh okay, thanks for explaining what happened. Most likely the file was just named wrong in the first place and was actually a PNG file all along. ShaderMap fully supports JPEG images.

    After the SM4.1 update all Start Actions are completed by LUA scripts. I’ll need to improve the output messages. Most likely the specifics are getting dumped into the script thread log.

    Glad you got it working.
Sign In or Register to comment.